Corrigindo besteiras no python3/dist-packages

Se por acaso você se deparar com o erro abaixo no arquivo /usr/lib/python3/dist-packages/setuptools/py33compat.py:

unescape = getattr(html, ‘unescape’, html_parser.HTMLParser().unescape)
AttributeError: ‘HTMLParser’ object has no attribute ‘unescape’

É pq a porcaria do HMLParser foi deprecated, pra corrigir, altere assim:

#unescape = getattr(html, ‘unescape’, html_parser.HTMLParser().unescape)
unescape = getattr(html, html.unescape(‘unescape’))


Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Crie seu site com o WordPress.com
Comece agora
%d blogueiros gostam disto: